Start Learning Korean in the next 30 Seconds with
a Free Lifetime Account

Or sign up using Facebook

Installing Korean in your Windows XP

Can't get the new lesson to play? Having troubles downloading the supplemental material? Post your technical questions here, and we'll help you out.
hyunwoo
Expert on Something
Posts: 868
Joined: August 1st, 2007 8:15 am
Location: Seoul Korea
Contact:

Installing Korean in your Windows XP

Postby hyunwoo » August 23rd, 2007 1:14 pm

Here's what Steve wrote in a different section of the forum, and I'm copying it here hoping that this will be of help for those who have problems with seeing or typing Hangul.

__________________________________________________________

If you are running XP go to Control Panel -> Regional and Language Options -> Language Tab (at the top). There you should check the "Install files for East Asian laguages" box. Also, go to the Details button and "Add.." the Korean keyboard for the IME system. I think that should do it. With IME installed you will either see a bar at the top of your screen or in the lower right hand corner to the left of the system tray showing what keyboard you have selected. With the Korean keyboard selected hitting the right ALT key will toggle between the English and Korean fonts so you can then type in Korean. Very Happy . Right-clicking on the IME bar will give you more display options, left-clicking letting you choose a keyboard. You can also install the Japanese keyboard there too so you can type in Japanese as well! You shouldn't need to install a language dependent operating sytem unless you are running windows 95 which you shouldn't be running anyway Wink . I think the instructions in the link above that Hyunwoo posted should get the fonts to display in the browser you are using.
Is this information detailed anywhere else in the forums? Perhaps this belongs in the technical section.
Anyway, Welcome and good luck!

__________________________________________________________

JockZon
Expert on Something
Posts: 106
Joined: August 13th, 2007 7:21 pm

Postby JockZon » August 23rd, 2007 7:42 pm

I also wrote this (about win XP) in the sticky about hangul. Maybe someone could tell me how I do in linux? ^^

Get 35% OFF
steved
Expert on Something
Posts: 211
Joined: August 16th, 2007 2:18 am

Postby steved » August 24th, 2007 12:11 am

Which LInux distribution are you using? I know that Ubuntu has an integrated IME-type setup.

Ulver_684
Expert on Something
Posts: 128
Joined: August 14th, 2007 7:41 am
Location: 뉴욕
Contact:

Re: Installing Korean in your Windows XP

Postby Ulver_684 » September 15th, 2007 2:00 am

hyunwoo wrote:Here's what Steve wrote in a different section of the forum, and I'm copying it here hoping that this will be of help for those who have problems with seeing or typing Hangul.

__________________________________________________________

If you are running XP go to Control Panel -> Regional and Language Options -> Language Tab (at the top). There you should check the "Install files for East Asian laguages" box. Also, go to the Details button and "Add.." the Korean keyboard for the IME system. I think that should do it. With IME installed you will either see a bar at the top of your screen or in the lower right hand corner to the left of the system tray showing what keyboard you have selected. With the Korean keyboard selected hitting the right ALT key will toggle between the English and Korean fonts so you can then type in Korean. Very Happy . Right-clicking on the IME bar will give you more display options, left-clicking letting you choose a keyboard. You can also install the Japanese keyboard there too so you can type in Japanese as well! You shouldn't need to install a language dependent operating sytem unless you are running windows 95 which you shouldn't be running anyway Wink . I think the instructions in the link above that Hyunwoo posted should get the fonts to display in the browser you are using.
Is this information detailed anywhere else in the forums? Perhaps this belongs in the technical section.
Anyway, Welcome and good luck!

__________________________________________________________


Hyunwoo-sun! :wink:

I have Windows Vista so would this work for Vista too :?

steved
Expert on Something
Posts: 211
Joined: August 16th, 2007 2:18 am

Postby steved » September 15th, 2007 2:50 am

In Vista from the Regional and Language panel you go to the Keyboard and Language tab and then use the Change Keyboard option. There you can install the Korean keyboard/IME support.

javiskefka
Expert on Something
Posts: 454
Joined: January 10th, 2008 6:01 pm
Location: Norman, Oklahoma
Contact:

Postby javiskefka » January 16th, 2008 2:36 am

JockZon wrote:I also wrote this (about win XP) in the sticky about hangul. Maybe someone could tell me how I do in linux? ^^


If you have a Debian-based distribution, it should be fairly simple. Install the scim package. It should get added to your Applications menu. When you run it, a keyboard icon will show up on the upper right of your desktop. Click on it, select Korean, then select the keyboard layout. I think the top most one is the standard one you will see in S. Korea. Let me know if you have any problems!

javiskefka
Expert on Something
Posts: 454
Joined: January 10th, 2008 6:01 pm
Location: Norman, Oklahoma
Contact:

Postby javiskefka » February 25th, 2008 10:09 pm

I have seen a couple old posts about problems that people had running Korean programs on their English language systems. Even though they had East Asian languages support installed, the text would show up is incorrect symbols like: A`&c3

Here's how to fix this problem. There's a more technical explanation, but basically, the program is coded for a system running Korean Windows, so since your computer is running English windows, the wrong character is displayed. There is a Microsoft program called AppLocale which enables you to start a program with a different codepage from your system default (like Korean!). You can get it here: Install AppLocale utility and find out more detailed information here: The Microsoft AppLocale Utility.

After you have installed this, you can run it, then select the application that you want to start, along with the language (select 한국어 from the bottom of the list), and if you want to create a shortcut for running the application in this way for the future. This will allow you to run whatever you were unable to before, because now you can actually tell what that button says!

the_haunted_boy
Expert on Something
Posts: 100
Joined: February 27th, 2008 1:36 am
Location: Boise
Contact:

Postby the_haunted_boy » February 28th, 2008 7:30 am

Whenever I do that it says I need Windows XP Professional Service Pack 2 CD, but I don't have it. On my laptop Korean was already on it, almost like a default. (I don't actually know a lot about computers, just basics.)

matthew254
Expert on Something
Posts: 282
Joined: May 9th, 2008 3:55 am
Location: 서울
Contact:

Postby matthew254 » May 10th, 2008 1:02 pm

the_haunted_boy wrote:Whenever I do that it says I need Windows XP Professional Service Pack 2 CD, but I don't have it.


I know its a bit old, but I had the same problem a long time ago.

Okay so my computer is from an OEM company (and online custom company that makes setups from scratch) and when I bought the setup, I had them install WinXP Pro. Pretty standard. What was different was that it was the OEM version of WinXP. All that means is that it is a cheaper version, but still full featured and works exactly like a retail version, just no shiny box, and NO backup DVD. only thing I got was a restore DVD in case I want to bring it all back to factory settings.

This may or may not be your case. You say that the computer aks for the SP2 DVD/CD and that's right. Microsoft wanted to save storage space by having the East Asian languages on a separate CD/DVD. It doesn't really save that much space, but I understand why they would want to do this on an American English version.

You essentially have two options. you can 1) find a friend and use their CD/DVD and it will work just fine or
2) find a nice person to upload the (i think) half a gig folder that contains all that you need online for you.

in my case, since i know a little bit about this kind of stuff, i went to a website that has like million .dll and .bin files. think of them as puzzle pieces for almost any program...and I just requested someone online that they post the list of "puzzle pieces" and I went to work downloading each and every one at a time. Took about 2 hours actually. not proud, but i have Korean IME on my legit copy of Windows!

anyways, this may or may not help, but for anyone else possibly needing this info, I hope it helps.

matthew254
Expert on Something
Posts: 282
Joined: May 9th, 2008 3:55 am
Location: 서울
Contact:

Postby matthew254 » September 22nd, 2008 8:36 am

here's a screenshot that has helped some others out that should be here.
http://i104.photobucket.com/albums/m166 ... hangul.jpg
anyone still having trouble installing Korean on Windows XP should check out the link above.

hyunwoo
Expert on Something
Posts: 868
Joined: August 1st, 2007 8:15 am
Location: Seoul Korea
Contact:

Postby hyunwoo » September 22nd, 2008 8:40 am

This will be very helpful for a lot of people, Matthew ; ) Thanks!

John
Expert on Something
Posts: 322
Joined: August 21st, 2007 2:51 am
Location: Illinois USA
Contact:

Postby John » February 5th, 2009 11:14 pm

ok all of the sudden I can't type in Korean anymore, I removed and re-installed the IME, but I can't get the "A" to come up anymore. It says KO Korean with the globe and Korean Input System but I can only type in English. :evil:

javiskefka
Expert on Something
Posts: 454
Joined: January 10th, 2008 6:01 pm
Location: Norman, Oklahoma
Contact:

Postby javiskefka » February 6th, 2009 12:06 am

John wrote:ok all of the sudden I can't type in Korean anymore, I removed and re-installed the IME, but I can't get the "A" to come up anymore. It says KO Korean with the globe and Korean Input System but I can only type in English. :evil:


I'm not sure how it could suddenly disappear, but here are some ways I can think of to make it come back:

1. Make sure that "additional icons in taskbar" is checked when you right click o nthe language bar
2. Expand the language bar as long as possible, to make sure that the "A" icon isn't hidden somewhere to the right
3. Make sure that advanced text services are not disabled. (Not sure how to get to this setting. Type "advanced text services" in windows help to get there)
4. Make sure that the Korean keyboard is installed (Settings for the language bar, Selct Korean click Add)

John
Expert on Something
Posts: 322
Joined: August 21st, 2007 2:51 am
Location: Illinois USA
Contact:

Postby John » February 6th, 2009 1:06 am

3. Make sure that advanced text services are not disabled. (Not sure how to get to this setting. Type "advanced text services" in windows help to get there)


That was it.....thx!! :lol:

javiskefka
Expert on Something
Posts: 454
Joined: January 10th, 2008 6:01 pm
Location: Norman, Oklahoma
Contact:

Postby javiskefka » February 6th, 2009 11:00 am

John wrote:3. Make sure that advanced text services are not disabled. (Not sure how to get to this setting. Type "advanced text services" in windows help to get there)


That was it.....thx!! :lol:


Excellent! The same thing happened on my work computer, so that's how I found out about that setting.


Return to “Technical Support (기술 지원)”